How to upgrade Debian Lenny to Squeeze

I use Slicehost and typically provision Debian Lenny.  But, after trying to install Beanstalkd, I found out that Lenny doesn’t support the required package, libevent-dev (1.4+).  Time to upgrade my slice to Squeeze.

Here’s how to do it:

Edit sources.list

sudo nano /etc/apt/sources.list

Change any word Lenny to Squeeze, (or from stable to testing) and save it.  Backup your original file, just to be safe

Updating and upgrading

sudo aptitude update

sudo aptitude install apt dpkg aptitude

sudo aptitude full-upgrade

Thats it.  You will be prompted with a few screens to authorize the upgrading or removal of certain packages and/or dependencies.  Take note of which packages will be altered before you proceed.

After this, you should be on running Debian Squeeze. Note: It is better to use Squeeze instead of testing.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: